3rd party: payment declined issue
Incident Report for iClassPro
Resolved
On March 4, 2024 from 5:15 am (CT) - 8:07 am (CT), some transactions made using an integrated terminal with iClassPro may have been declined due to an issue with a third party processing partner. The problem has been resolved and that we and our partner will continue to monitor the application to ensure it is behaving properly. Thank you.
Posted Mar 04, 2024 - 09:07 CST
Monitoring
One of our third party partners is currently experiencing an issue where some transactions attempted on an integrated terminal through iClasspro may be declined. Our partner is working to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause. Thank you
Posted Mar 04, 2024 - 08:28 CST
This incident affected: 3rd Party Integration/Provider.