Availability
Incident Report for iClassPro
Resolved
We appreciate your patience while we worked through this issue and want to let you know that the problem is now resolved. We will continue monitoring the application to ensure it behaves properly. Again, thank you.
Posted May 15, 2023 - 13:47 CDT
Update
We are continuing to investigate this issue.
Posted May 15, 2023 - 11:29 CDT
Investigating
We are currently experiencing an issue impacting some iClassPro customers' ability to connect to the software. We are working on resolving the issue as quickly as possible and apologize for any inconvenience this may cause. Thank you.
Posted May 15, 2023 - 11:09 CDT
This incident affected: iClassPro Application, Enterprise Portal, Customer Portal, and Staff Portal.