Third Party: SPF issues
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted Jan 21, 2024 - 06:06 CST
Identified
One of our third-party partners is experiencing an issue that is causing intermittent issues with the Secure Payment Form. They have identified the problem, and we are working with our partner to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause. Thank you.
Posted Jan 20, 2024 - 23:59 CST
This incident affected: 3rd Party Integration/Provider.