Interrupted Service
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted Sep 10, 2018 - 16:34 CDT
Investigating
We are currently investigating an issue that is impacting the application. Please accept our apologies for the interruption, we are working to restore access as quickly as possible.
Posted Sep 10, 2018 - 16:10 CDT
This incident affected: iClassPro Application and Staff Portal.