Unable to Refund Customer Portal Payments

Incident Report for iClassPro

Resolved

Our team has identified the root cause of the issue and released a fix to correct the matter. We appreciate your patience while we worked to resolve this issue, and if you have any questions, don't hesitate to contact our support team.
Posted Mar 20, 2025 - 18:47 CDT

Investigating

Our team is investigating an issue that is preventing refunds for payments taken via the Customer Portal. We will continue to update this message as the issue progresses until it is resolved.
Posted Mar 20, 2025 - 14:52 CDT
This incident affected: iClassPro Application.