Support interface is currently down
Incident Report for iClassPro
Resolved
Thank you for your patience while our third-party partner worked through this issue. We want to let you know that the problem is now resolved and that we, along with our partner, will continue to monitor the application to ensure it behaves properly. Again, thank you, and we apologize for any inconvenience this may have caused.
Posted Mar 15, 2023 - 19:19 CDT
Investigating
One of our third-party partners is experiencing an issue that is impacting the ability of iClassPro customers to contact support. We are working with our partner to resolve the issue as quickly as possible and apologize for any inconvenience this may cause. Thank you.
Posted Mar 15, 2023 - 18:20 CDT
This incident affected: Support Website and Support Telephone System.