Enrollments Issue
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted Jun 15, 2022 - 14:58 CDT
Investigating
We are aware of an issue that may be affecting enrollments via the Office Portal and our team is currently investigating.
Posted Jun 15, 2022 - 14:39 CDT
This incident affected: iClassPro Application.