Issue with Customer Portal Payments
Incident Report for iClassPro
Resolved
We appreciate your patience while we worked through this issue and want to let you know that the problem is now resolved. We will continue monitoring the application to ensure it behaves properly. Again, thank you.
Posted Jan 05, 2024 - 12:50 CST
Identified
Our Development team has identified the cause of the issue. We continuing our work to fully resolve the problem and will follow up with more information as it becomes available.
Posted Jan 05, 2024 - 12:02 CST
Investigating
We are currently experiencing an issue impacting some iClassPro customers' ability to receive payments through the Customer Portal. We are working on resolving the issue as quickly as possible and apologize for any inconvenience this may cause.
Posted Jan 05, 2024 - 10:17 CST
This incident affected: Customer Portal.