Enrollment Wizard Charges

Incident Report for iClassPro

Resolved

Our team had identified the impact and reached out to our affected clients. We appreciate your patience while we worked to resolve this issue, and if you have any questions, don't hesitate to contact our support team.
Posted Mar 20, 2025 - 18:25 CDT

Monitoring

Our team has released a fix to correct the root cause of this issue. We are currently determining impact to our clients. Thanks for your patience while we work to fully resolve this matter.
Posted Mar 19, 2025 - 15:01 CDT

Investigating

Our team is investigating an issue that has caused incorrect charge values to be populated when using the Enrollment Wizard. We will continue to update this message as the issue progresses until it is resolved.
Posted Mar 19, 2025 - 11:43 CDT
This incident affected: iClassPro Application.