Issue with Background task window not displaying progress
Incident Report for iClassPro
Resolved
After thorough review and monitoring, our team is confident that our previous updates have resolved the background task issues. We appreciate your exceptional patience while we worked through this issue and will continue to monitor the software for any signs of further issues.
Posted Feb 06, 2024 - 21:23 CST
Monitoring
Our team has released updates designed to target the core issue affecting our background tasks window. The behavior has been much improved today. However, we will continue to monitor system behavior over the weekend so that we can be fully confident that the improvements we're seeing are evidence of resolution.

Please continue contacting our support team before canceling any potentially stuck tasks so that we can confirm any necessary next steps before restarting any task.
Posted Feb 02, 2024 - 15:30 CST
Update
Our team is still investigating the cause behind the background tasks window not updating correctly. We are still working to identify the core issue causing the error. Please continue contacting our support team before canceling any potentially stuck tasks so that we can confirm any necessary next steps before restarting any task.
Posted Feb 01, 2024 - 18:36 CST
Investigating
Our development team has been made aware of an issue where the background tasks window is not updating to show progress. If a task appears stuck, please close the window and reopen it. If the task remains stuck, please contact our support team before canceling the task so that we can investigate that task directly.
Posted Feb 01, 2024 - 11:09 CST
This incident affected: iClassPro Application.