Class Tuition Charges
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted Jan 25, 2024 - 16:59 CST
Investigating
We are currently investigating an issue where some customers are experiencing delays when running class tuition charges.
Posted Jan 25, 2024 - 15:03 CST
This incident affected: iClassPro Application.