Payment Processing Errors

Incident Report for iClassPro

Monitoring

We have released an update to address the issue and have verified the unknown errors are no longer produced. We'll continue monitoring and we'll post updates as they become available.
Posted Apr 02, 2025 - 17:56 CDT

Update

We are continuing to investigate this issue, but have determined that it is limited to accounts located in Australia. We will continue to provide updates here as we continue our investigation.
Posted Apr 02, 2025 - 12:22 CDT

Investigating

Our team is currently investigating an issue causing some payments to return with an Unknown Error. We will continue updating this message as our investigation progresses.
Posted Apr 01, 2025 - 22:27 CDT
This incident affects: iClassPro Application.