Issue Impacting Payment Processing (US)
Incident Report for iClassPro
Resolved
Beginning around 7:00pm, one of our third-party partners experienced an issue that impacted the ability of US iClassPro customers to accept payments via credit card. Our partner resolved the payment functionality issue they were experiencing and the ability for US iClassPro customers to accept payments via credit card was restored around 7:55pm.
Posted May 17, 2022 - 20:00 CDT