Connectivity Issue
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 10:36 CDT
Investigating
We are currently experiencing an issue affecting mobile app connectivity for some Australian customers. We are working on resolving the issue as quickly as possible and apologize for any inconvenience this may cause. Thank you.

For questions, please feel free to reach out to our support team at 1.877.554.6776 or submit a request at
https://support.iclasspro.com/. Thank you.
Posted May 26, 2023 - 14:30 CDT
This incident affected: iClassPro Application.