Issue with Secure Payment Form
Incident Report for iClassPro
Resolved
On November 7, between approximately 9:47 am and 11:55 am, our secure payment form experienced loading issues. We have successfully resolved the problem and are actively monitoring the system to ensure it functions as intended.
Posted Nov 07, 2023 - 12:02 CST
Investigating
We are currently experiencing an issue with the secure payment form. We are currently investigating to identify the root cause and will provide updates as soon as additional details are available.
Posted Nov 07, 2023 - 10:00 CST
This incident affected: iClassPro Application.