Issue: Mastercard Experiencing Higher than Expected Failure Rates
Incident Report for iClassPro
Resolved
Mastercard has fully resolved an internal issue and restored service. We will continue to monitor the environment to ensure stability.
Posted Nov 13, 2024 - 15:27 CST
Monitoring
One of our third-party partners has informed us of an issue currently impacting transactions on the Mastercard network. They are actively working to identify and resolve the issue as quickly as possible.
Posted Nov 13, 2024 - 14:25 CST
This incident affected: iClassPro Payments.