Makeup Token Redemption

Incident Report for iClassPro

Resolved

Our team has identified the issue and released a fix to correct the matter. We appreciate your patience while we worked to resolve this issue, and if you have any questions, don't hesitate to contact our support team.
Posted Mar 21, 2025 - 10:09 CDT

Investigating

Our team is currently investigating an issue that is intermittently causing makeup tokens to be unusable from the Customer Portal or Mobile App. We will continue to update this message as the issue progresses until it is resolved.
Posted Mar 20, 2025 - 15:29 CDT
This incident affected: Customer Portal and Mobile Application.