Issue with Editing or Creating Camps
Incident Report for iClassPro
Resolved
Beginning around 10:15 CT, we detected an issue impacting the ability for some iClassPro customers to edit or create camps. We resolved the issue and you should now be able to perform the action noted above. We will continue to monitor the application to ensure it is behaving properly. We appreciate your understanding and apologize for any inconvenience this may have caused.

For questions, please feel free to reach out to our helpful support team at 1.877.554.6776 or submit a request at https://support.iclasspro.com/. Thank you.
Posted Nov 28, 2022 - 10:30 CST