Issue: Support desk issues.
Incident Report for iClassPro
Resolved
After working with our partners, the issues affecting our Support lines have been resolved.

Thank you for your patience while we resolved this issue!
Posted Apr 22, 2024 - 12:13 CDT
Identified
One of our third-party partners is experiencing an issue that is impacting the ability of some iClassPro customers to reach our customer support lines. We are working with our partner to resolve the issue as quickly as possible and apologize for any inconvenience this may cause. Thank you.

For questions, please feel free to submit a request at https://support.iclasspro.com/

Thank you.
Posted Apr 22, 2024 - 10:10 CDT
This incident affected: Support Telephone System.