Increased Login Prompts for Staff

Incident Report for iClassPro

Update

We are continuing to investigate this issue.
Posted Mar 12, 2026 - 20:08 CDT

Investigating

We are currently investigating an issue where some staff members are being prompted to log in more frequently than usual. Updates will be provided as more information becomes available.
Posted Mar 12, 2026 - 19:56 CDT
This incident affects: iClassPro Application and Staff Portal.