Investigating an issue with making payments

Incident Report for iClassPro

Resolved

This incident has been resolved.
Posted Sep 15, 2023 - 09:33 CDT

Monitoring

Our team has resolved the issue and we are continuing to monitor the status of the payment form.
Posted Sep 15, 2023 - 08:19 CDT

Investigating

We are currently investigating an issue with making payments.
Posted Sep 15, 2023 - 07:29 CDT
This incident affected: iClassPro Application, Customer Portal, and iClassPro Payments.