Issue with Partial Payments
Incident Report for iClassPro
Resolved
We appreciate your patience while we worked through this issue and want to let you know that the problem is now resolved. We will continue monitoring the application to ensure it behaves properly. Again, thank you.
Posted Apr 12, 2024 - 16:26 CDT
Investigating
We are currently experiencing an issue that is affecting the ability of a small subset of iClassPro customers to accept partial payments through the Customer Portal.

Customers are reporting the error message "The amount due changed between initiating the payment and authorizing the charge. Please submit a new payment request."

We are working on resolving the issue as quickly as possible and apologize for any inconvenience this may cause.
Posted Apr 12, 2024 - 13:42 CDT
This incident affected: Customer Portal.