Issue: Connectivity Issue
Incident Report for iClassPro
Resolved
We appreciate your patience while we worked through this issue and want to let you know that the problem is now resolved. We will continue monitoring the application to ensure it behaves properly. Again, thank you.
Posted Nov 29, 2023 - 16:55 CST
Update
The software has recovered to full functionality and appears stable. Our team is still monitoring the situation closely to ensure there are no further issues.
Posted Nov 29, 2023 - 16:30 CST
Update
We are continuing to monitor the system as it has not yet fully recovered. Our team is still working closely with our technology partner to restore the system to full functionality.
Posted Nov 29, 2023 - 15:19 CST
Monitoring
Our team is still working with our technology partner, we are seeing some improvement as the system has begun to recover. However, we are monitoring it closely to ensure that the system is stable before considering this resolved.
Posted Nov 29, 2023 - 14:46 CST
Update
Our team is still working with our technology partner to restore access to the software. We appreciate your patience as we work to resolve the issue.
Posted Nov 29, 2023 - 14:12 CST
Update
Our team is still working with our technology partner to restore access to the software. We appreciate your patience as we work to resolve the issue.
Posted Nov 29, 2023 - 13:41 CST
Identified
Our team has tracked the issue to a third-party integration and is working with our technology partner on a resolution.
Posted Nov 29, 2023 - 13:09 CST
Update
Our team is still investigating the underlying cause of the connectivity issues.

We apologize for the inconvenience this has caused
Posted Nov 29, 2023 - 12:39 CST
Investigating
We are currently experiencing an issue that is impacting the ability of iClassPro customers to connect to the application. Our Developers are working on resolving the issue as quickly as possible and apologize for any inconvenience this may cause. Thank you.

For questions, please feel free to reach out to our support team at 1.877.554.6776 or submit a request at https://support.iclasspro.com/.

Thank you.
Posted Nov 29, 2023 - 11:35 CST
This incident affected: iClassPro Application, Customer Portal, Staff Portal, and Mobile Application.