Connectivity Issue

Incident Report for iClassPro

Resolved

This incident has been resolved.
Posted Sep 20, 2023 - 21:07 CDT

Investigating

We are currently experiencing an intermittent issue that is impacting the ability of iClassPro customers to properly load some pages of iClassPro. We are working on resolving the issue as quickly as possible and apologize for any inconvenience this may cause. Thank you.
Posted Sep 20, 2023 - 18:16 CDT
This incident affected: iClassPro Application.