Secure Payment Form Issue
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted Jan 25, 2022 - 09:47 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 25, 2022 - 05:10 CST
Update
Our team is continuing work to resolve this issue.
Posted Jan 24, 2022 - 22:14 CST
Update
We are continuing work on a fix for this issue.
Posted Jan 24, 2022 - 20:46 CST
Identified
The issue has been identified and our team is working to fix the issue.
Posted Jan 24, 2022 - 19:54 CST
Investigating
We are aware of an issue affecting the secure payment form and are currently investigating a fix.
Posted Jan 24, 2022 - 19:04 CST
This incident affected: iClassPro Application, Customer Portal, and iClassPro Payments.