Support Desk Call Connectivity Issue
Incident Report for iClassPro
Resolved
Our service provider has reported a full recovery at their end.
We appreciate your support and patience.
Posted May 18, 2023 - 20:48 CDT
Monitoring
We are seeing recovery at our end with test inbound and outbound calls working, however we are still monitoring this issue closely, and will post an update here, once the issue has been fully resolved.
Posted May 18, 2023 - 19:33 CDT
Investigating
One of our third-party partners is experiencing an issue that is impacting the ability for some iClassPro customers to call into our support desk. We are working with our partner to resolve the issue as quickly as possible and apologize for any inconvenience this may cause.

In the meantime, you can still reach us by email at Support@iclasspro.com, or by submitting a ticket at https://support.iclasspro.com/hc/en-us/requests/new

Thank you.
Posted May 18, 2023 - 18:34 CDT
This incident affected: Support Telephone System.