Issue with Secure Payment Form
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted Jan 02, 2024 - 03:25 CST
Update
We are continuing to work on a fix for this issue.
Posted Jan 02, 2024 - 02:31 CST
Identified
We are currently experiencing an issue with the secure payment form. We have identified the root cause and will provide updates as soon as additional details are available.
Posted Jan 02, 2024 - 02:30 CST
This incident affected: iClassPro Payments.