Support Communication Outage
Incident Report for iClassPro
Resolved
The outage we were experiencing with our third-party support system software has been resolved. Please accept our apologies for the interruption.
Posted about 1 month ago. Sep 16, 2019 - 14:23 CDT
Investigating
We are currently experiencing an outage with our third-party support system software. Please accept our apologies for the interruption. We are hoping functionality will be restored as quickly as possible. Please check back for updates on this issue.
Posted about 1 month ago. Sep 16, 2019 - 13:22 CDT
This incident affected: Support Website and Support Telephone System.