Support outage
Incident Report for iClassPro
Resolved
Connectivity has been restored.
Posted 5 months ago. May 31, 2019 - 15:59 CDT
Investigating
We are currently experiencing connectivity problems at iClassPro offices that are prohibiting us from being available for phone support.
Posted 5 months ago. May 31, 2019 - 15:38 CDT
This incident affected: Support Telephone System.