Long running tasks
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 20:40 CDT
Investigating
One of our third-party partners is experiencing an issue that is causing some background processes to take longer than expected to complete. We are working with our partner to resolve the issue as quickly as possible and apologize for any inconvenience this may cause. Thank you.

For questions, please feel free to reach out to our support team at 1.877.554.6776 or submit a request at https://support.iclasspro.com/. Thank you.
Posted Mar 26, 2024 - 16:36 CDT
This incident affected: 3rd Party Integration/Provider.