January 10 release issues
Incident Report for iClassPro
Postmortem

This morning’s update marks the culmination of over two years of programming effort to migrate the iClassPro financial ledger to a new, more efficient platform. For several months, iClassPro has been maintaining two ledgers side by side. This morning’s push completely deprecated the old ledger and all aspects of iClassPro are now utilizing the new ledger platform.

Due to some unforeseen discrepancies between our production database environment and the multiple testing environments that were used during development and QA testing, the application began logging errors as users attempted to create new charges and payments. The decision was made to place the application in maintenance mode to pinpoint the problem and prevent further errors from occurring.

A code change was developed that addressed the discrepancy in how the database was handling a particular save transaction and further testing began. The error logs revealed a few more errors that were quickly addressed and the application was put back into production mode.

Important Note: It’s possible that some credit card or eCheck payments may have processed through the payment gateway without being saved in iClassPro between at 8:35 am CST and 10:00 am CST. We recommend logging into your payment gateway to check the recent transactions. If the payment is in the gateway but not in iClassPro, you can record that transaction in iClassPro by using the “Credit Card External” payment type. If you need help with this, please feel free to reach out to our support team at 877-554-6776.

iClassPro Merchant Services Customers: If you are an iClassPro Merchant Services customer, we have already entered any transactions processed during that time frame on your behalf. Those transactions are recorded as Credit Card External. To review these transactions, you can generate the bank deposit report for the Credit Card External payment type. The transaction ID will show in the reference field. Some of these payments may have saved as unapplied credit. If you need the full transaction details or need to process refunds for any these transactions, you can do so by logging into the payment gateway directly at payments.iclasspro.com/login.

We are continuing to monitor the system and address support tickets as they come in. If you have a problem or question, please submit a full description of the issue or question to support@iclasspro.com.

Posted Jan 10, 2017 - 16:25 CST

Resolved
While there are a few tickets still open and we are still closely monitoring the situation, the issues that caused this morning's unanticipated maintenance period are resolved. More details to be posted soon.
Posted Jan 10, 2017 - 16:17 CST
Monitoring
The application is back up, and we are continuing to monitor it closely.
Posted Jan 10, 2017 - 12:11 CST
Update
We're almost there! We're still working on a couple issues before bringing the application back up. Thank you for your patience.
Posted Jan 10, 2017 - 11:07 CST
Update
We are making some finishing touches, and we should be back up soon. Thank you for your patience!
Posted Jan 10, 2017 - 10:36 CST
Identified
We have identified the issue and we are working on pushing it out to production. We'll provide another update very soon.
Posted Jan 10, 2017 - 10:04 CST
Update
The application has been taken offline to maintain data integrity while we work through the charge and payment issues. Please accept our apologies for the interruption, and we'll post more information here as soon as it's available.
Posted Jan 10, 2017 - 09:55 CST
Investigating
We are investigating issues creating new charges and payments after this morning's update.
Posted Jan 10, 2017 - 09:20 CST