Support Center Communications
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 28, 2017 - 17:31 CST
Monitoring
Our customer success center is now able to take calls. We will continue to monitor for call quality and potential interruptions as the day progresses.
Posted over 1 year ago. Feb 28, 2017 - 15:15 CST
Identified
A major east coast outage is affecting our customer success center's phone system operations. Please direct any questions to tickets, email (support@iclasspro.com) and chats until our phones are up and running.
Posted over 1 year ago. Feb 28, 2017 - 14:44 CST