Interrupted Service
Incident Report for iClassPro
Resolved
This incident has been resolved. We will continue to monitor the application closely. Thank you for your patience!
Posted 4 months ago. Jun 10, 2019 - 19:37 CDT
Monitoring
A change has been implemented and we are monitoring the results.
Posted 4 months ago. Jun 10, 2019 - 19:15 CDT
Investigating
We are currently investigating an issue that is impacting the application. Please accept our apologies for the interruption, we are working to restore access as quickly as possible.
Posted 4 months ago. Jun 10, 2019 - 19:05 CDT
This incident affected: iClassPro Application, Parent Portal, and Staff Portal.