Interrupted Service
Incident Report for iClassPro
Resolved
The issue has been resolved and full functionality has been restored. Sorry for the interruption.
Posted 11 months ago. Aug 23, 2017 - 10:03 CDT
Identified
We've identified the problem that caused this morning's issue and are working to resolve it. Full functionality should be restored soon.
Posted 11 months ago. Aug 23, 2017 - 09:47 CDT
Investigating
We are currently investigating an issue that is impacting the iClassPro application. Please accept our apologies for the interruption, we are working to restore full functionality as quickly as possible.
Posted 11 months ago. Aug 23, 2017 - 09:35 CDT