Slow Response Times
Incident Report for iClassPro
Postmortem

Summary:

Yesterday from approximately 3:30pm CST to 6:45pm CST we experienced degraded performance of the system causing much slower than usual response times and some reports not fully generating.

Please accept our sincere apologies for the inconvenience this problem caused. Ensuring application reliability and up-time is always of the utmost importance to us, and it's a responsibility we take seriously. As soon as we became aware of the problem, our team went to work troubleshooting to bring the quickest resolution possible.

Root Cause:

The problem was caused do to all of the application load not properly balancing across our server cluster. As soon as we identified the root cause of the problem, we released a fix to address the issue. After monitoring for several hours after the fix was released, we did see the load begin to properly balance across our entire server cluster restoring normal response times.

What we are doing about it:

To prevent this problem from happening again, we’ve released a code change to properly balance load across our server cluster. We've added some additional monitoring to ensure that the load stays balanced across the server cluster at all times. Our server admins will continue monitoring the servers closely.

For more information:

Please subscribe to our status page to get the most current information about any service issues. We also record all incidents and application response times on this page. If you have any further questions about this incident, please feel free to contact iClassPro support by emailing us at support@iclasspro.com or calling 877-554-6776.

Posted Feb 03, 2015 - 15:28 CST

Resolved
Our servers are now operating normally. We will continue to monitor the server status throughout the evening. Please accept our sincere apologies for the inconvenience this issue caused, and we will continue working to prevent this issue from happening again.
Posted Feb 02, 2015 - 19:09 CST
Identified
We have identified the root cause of slower than usual load times, and we're working with our server admins to resolve as quickly as possible.
Posted Feb 02, 2015 - 17:56 CST
Investigating
Due to a higher than usual server load, some customers are experiencing longer wait times and timeouts on resource intensive requests such as reports. Our development staff is working on resolving this issue as soon as possible.
Posted Feb 02, 2015 - 16:52 CST