Inbound Support Calls
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted 5 months ago. May 10, 2018 - 10:45 CDT
Investigating
Our 3rd party support solution is currently experiencing downtime. We are currently unable to receive in-bound support calls.
Posted 5 months ago. May 10, 2018 - 09:06 CDT
This incident affected: Support Telephone System.