Payment Processing Disruption Due To Widespread DNS Issues
Incident Report for iClassPro
Resolved
Processing is running normally and no further disturbances have been observed. We will continue to monitor the situation and post updates as necessary to our status page at http://status.iclasspro.com/.

Several gateways and payment processors including iClassPro Merchant Services' gateway were affected by the DDoS attacks on Dyn. Dyn is a DNS hosting provider for many websites including some big names such as Netflix, Twitter and Spotify.

The event prevented access to the payment gateway intermittently between approximately 12:30pm CST and 2:38pm CST. During this time, some customers may have received an error message that a payment or an attempt to store payment information "could not be processed at this time" in both the staff side of the software and the parent portal.

As a precaution, we recommend checking the transactions in the gateway today against those which are recorded on the bank deposit report in iClassPro to ensure that all payments are recorded accurately. For iClassPro Merchant Services customers, you can access the gateway login from https://payments.iclasspro.com/login.
Posted about 1 year ago. Oct 21, 2016 - 16:42 CDT
Monitoring
The payment gateway services are restored, and we will continue to monitor closely and update the status as needed.
Posted about 1 year ago. Oct 21, 2016 - 15:38 CDT
Identified
The iClassPro payment gateway is currently experiencing connectivity issues due to widespread DNS issues affecting a number of websites. This is causing some customers not to be able to process payments or store payment information in iClassPro or the parent portal.

The DNS issues are being caused by a major DDoS attack on Dyn which is a DNS host for many websites including our payment gateway and other major websites like Twitter, Etsy, Spotify, and more. Dyn is also updating their current status here: https://www.dynstatus.com/incidents/nlr4yrr162t8

We are monitoring closely and will update the status page with more information as soon as it becomes available.
Posted about 1 year ago. Oct 21, 2016 - 15:10 CDT