Issue with Payment Functionality
Incident Report for iClassPro
Resolved
This incident was resolved as of 12:30 pm (CT).
Posted Jun 23, 2022 - 22:16 CDT
Investigating
At approximately 12:19 pm (CT), we experienced an issue that impacted the ability for US iClassPro customers to accept payments via credit card or eCheck. The payment functionality issue was resolved and the ability for US iClassPro customers to accept payments via credit card or eCheck was restored at 12:30 pm (CT). We will continue to monitor the application to ensure it is working properly.
Posted Jun 23, 2022 - 15:31 CDT
This incident affected: iClassPro Payments.