Applications errors
Incident Report for iClassPro
Resolved
The database layer is running at full capacity. We will be reviewing logs with our database administrators and the vendor support team to determine the cause of the problem.
Posted about 2 months ago. Oct 19, 2017 - 07:39 CDT
Update
We have taken the application out of maintenance mode. Database recovery is still in progress and we will continue to make updates.
Posted about 2 months ago. Oct 19, 2017 - 02:03 CDT
Update
We will be placing the application in maintenance mode in 10 minutes in order to bring our full database layer back into production.
Posted about 2 months ago. Oct 18, 2017 - 23:50 CDT
Update
The unexpected failure of the database layer earlier today is still under investigation. The system was discovered to have a highly unusual backlog of transactions waiting to be saved. While performing a routine restart one of our databases, it caused an unexpected, immediate failure of the system as a whole. We then encountered unusual difficulty in bringing the entire system back online.

The database administrators found a configuration setting that appears to have caused abnormally long update times under certain circumstances. This configuration setting was changed and the application has been running well even on reduced system capacity. In order to bring the database layer back up to full capacity, we need to schedule about 30 - 45 minutes of downtime to sync all the systems. We will begin this process at midnight Central time (US) tonight.
Posted about 2 months ago. Oct 18, 2017 - 19:34 CDT
Update
We are currently running on reduced database layer capacity, but the application should be available for use. We'll continue to provide updates as we progress through this recovery.
Posted about 2 months ago. Oct 18, 2017 - 10:59 CDT
Update
Full database recovery is underway. 30+ minutes may be necessary.
Posted about 2 months ago. Oct 18, 2017 - 10:16 CDT
Update
We found one of the database servers needed to have the software restarted. When it was restarted, the entire database layer failed. We are working very hard to get it back online.
Posted about 2 months ago. Oct 18, 2017 - 10:08 CDT
Investigating
iClassPro is investigating the cause of application errors.
Posted about 2 months ago. Oct 18, 2017 - 09:49 CDT