Support Outage
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 03, 2019 - 14:50 CDT
Identified
We are currently experiencing connectivity problems at iClassPro offices that are limiting our phone support availability
Posted 3 months ago. Jun 03, 2019 - 09:29 CDT
This incident affected: Support Telephone System.