iClassPro Merchant Services Outage
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 27, 2017 - 10:07 CDT
Update
Our payment processing provider has reported that their services have returned to normal. We will continue to monitor the situation. Thank you for your patience!
Posted 3 months ago. Sep 27, 2017 - 09:50 CDT
Monitoring
Our gateway provider is restoring access. There may be a period of increased latency while they continue to restore the service. We will continue to update the status page as more information is available.
Posted 3 months ago. Sep 27, 2017 - 09:41 CDT
Identified
A provider for our payment platform is currently experiencing an outage. Customers using iClassPro Merchant Services, Process Pink and SafeSave are not currently able to process payments. We will continue to update our status page as new information is available.
Posted 3 months ago. Sep 27, 2017 - 09:06 CDT