Issue
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 06, 2017 - 15:43 CST
Monitoring
Our team has issued a fix to correct login issues. If you're experiencing issues logging in, please try clearing the cache and cookies in your web browser to ensure that you are getting our most recent update. If you are not sure how to do this, instructions have been provided for our recommended browsers below:

Google Chrome Users - Follow the instructions in the link below:
https://support.google.com/accounts/answer/32050?co=GENIE.Platform%3DDesktop&hl=en

Firefox Users - Follow the instructions in the link below using the time range of "Everything" and the checked options for "Cache" and "Cookies"
https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

If you continue to have issues, please reach out to our support team so that we can troubleshoot further (via phone 903.353.9329 or via web at: https://support.iclasspro.com/hc/en-us/requests/new).
Posted about 1 month ago. Nov 06, 2017 - 14:16 CST
Investigating
Some users are reporting an issue that is impacting access to the iClassPro application. Please accept our apologies for the interruption, we are working to restore functionality as quickly as possible.
Posted about 1 month ago. Nov 06, 2017 - 12:37 CST