Issue
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 11, 2017 - 13:19 CDT
Investigating
Some users are reporting an issue that is impacting access to the iClassPro application. Please accept our apologies for the interruption, we are working to restore functionality as quickly as possible.

If you are seeing errors when attempting to process payments, please double check your gateway to verify if the payment was actually processed or not. These payments may need to be manually recorded in iClassPro.
Posted 2 months ago. Oct 11, 2017 - 11:20 CDT