Problems with Camp module
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted 8 months ago. Apr 20, 2017 - 13:53 CDT
Identified
Some customers may be experiencing problems related to enrollments and administration of Camps. The source of the problem has been identified and corrective actions are underway.
Posted 8 months ago. Apr 20, 2017 - 12:40 CDT