Delayed Email Delivery
Incident Report for iClassPro
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 20, 2018 - 10:56 CDT
Identified
We're currently experiencing an issue with our email provider. Emails sent from iClassPro will be delivered but may be slightly delayed – your emails are queued and there is no need to resend them. We'll update here as soon as the issue is resolved.
Posted about 1 month ago. Mar 20, 2018 - 10:46 CDT