Some Credit Card Transactions are Timing-Out
Incident Report for iClassPro
Resolved
We have confirmed that transactions are now processing through successfully. There have been no further connection issues observed since about 2:57 PM CST. If you received any decline transaction messages between 10:52 AM and 2:57 PM CST, you should now be able to re-attempt the transaction. We apologize for any inconvenience this may have caused. Please contact our support team at support@iclasspro.com or 877-554-6776 if you have any questions.
Posted 8 months ago. Jan 03, 2019 - 15:14 CST
Monitoring
Transactions are now processing through successfully. We will continue to monitor the situation closely.
Posted 8 months ago. Jan 03, 2019 - 14:51 CST
Update
Our back-end processor is still working to mitigate the impact as quickly as possible. The incident appears to be a result of a high-level network outage, affecting multiple providers (Level 3 and Verizon) across portions of the continental United States. Some transactions are not reaching the processor as a result. More updates will be provided as soon as more information is available.
Posted 8 months ago. Jan 03, 2019 - 14:43 CST
Update
Our back-end processor is still working to mitigate the impact as quickly as possible. We have no other updates at this time.
Posted 8 months ago. Jan 03, 2019 - 13:15 CST
Update
Our back-end processor is still working to mitigate the impact. The incident appears to be a result of a high level Verizon network outage affecting multiple portions of the continental United States, primarily in the Northeast. Technical resources have escalated the issue with Verizon, and have rerouted traffic to Level 3 circuits to avoid the affected Verizon pathway. However, Level 3 circuits are experiencing latency in traffic which is affecting transaction processing.
Posted 8 months ago. Jan 03, 2019 - 12:26 CST
Update
The incident appears to be a result of a high level Verizon network outage affecting multiple portions of the continental United States, primarily in the Northeast. The issue has been escalated with Verizon and engineers are working to route traffic to other circuits to mitigate impact.
Posted 8 months ago. Jan 03, 2019 - 11:50 CST
Identified
Our back-end processor is experiencing an issue causing some transactions to time-out. We are monitoring the situation closely and will provide updates as they become available.
Posted 8 months ago. Jan 03, 2019 - 11:21 CST
This incident affected: iClassPro Merchant Services.